Startseite‎ > ‎Microsoft‎ > ‎Excell‎ > ‎

Dropdown-Liste über 2 Spalten

In der Tabelle "Produkte" stehen die Daten in 2 Spalten.

In der Tabelle "Monat" sollen die Daten als Dropdown-Liste gewählt werden können.

1. In der Tabelle "Produte" die Daten der ersten Spalte  markieren > rechte Maustaste > Bereich benennen  (zBp. als "Datenbestand" benennen)

2. in der Tabelle Monat die entsprechende Zelle der ersten Spalte markieren
    > Reiter "Daten" > Datenüberprüfung > Datenüberprüfung >
    Zulasse: Liste       
    Quelle:  =Datenbestand
Damit ist die Dropdown-Liste in der Zelle eingerichtet

Damit die zweite Spalte sich in Abhängigkeit von der Auswahl in der ersten Spalte verändert, muss da eine Formel hinein:

=SVERWEIS($A$1;Produkte!A:F;2;FALSCH)

Dabei muss $A$1  auf die Zelle mit der Dropdown-Liste verweisen, und der Tabellenname auf die Tabelle mit dem Datenbestand

Für Daten aus der 3-ten Zeile:     =SVERWEIS($A$1;Produkte!A:F;3;FALSCH)
Für Daten aus der 4-ten Zeile:     =SVERWEIS($A$1;Produkte!A:F;4;FALSCH)
usw...
Comments